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e Adobe Indesign Basics



Pattern Design in lllustrator



Schets overtrekken
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|| Shapebuilder-tool

1. Maak een foto van je schets en plaats deze in je document. File > Place

2. Maak de schets transparanter (Opacity) en zet de laag op slot.

3. Maak een nieuw laag aan en teken met de pen-tool of de pencil-tool je schets over. Zorg dat je
viak geen vulling heeft, en geef je lijn een dikte.

Viakken inkleuren met shapebuilder tool

1. Selecteer de tekening met de selectie-tool

2. Ga naar swatches, kies een kleur

3. Klik de shapebuilder-toal,

4. Selecteer het vliak wat je wilt inkleuren. Als deze grijs wordt klik je op het viak.

Ankerpunt bewerken

1. Maak een cirkelvorm

2. Selecteer het witte pijltje (direct selectie-toaol), klik eerst
buiten de tekening. Selecteer daarna 1 van de ankerpunten
en maak hier een scherpe hoek van > convert bovenin.
Andersom kun je scherpe hoeken omzetten naar ronde
hoeken.

lllustrator Tutorials Design Patterns 2

Werken met symbolen
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Pattern Options

1. Selecteer je tekening.

2. Ga naar Object > Pattern >
Make.

3. Typ een naam in het Pattern
Options venster

4. Maak een keuze voor een
van de Tile types:

- Grid

- Brick by Row (1/2 verzet)

- Brick by Column (1/2 drop)

- Hex by Column

- Hex by Row

5. Door de breedte en hoogte
van de tegel aan te passen
schuif je het patroon in- en uit
elkaar.

6.Kies boven voor Done

Je patroon verschijnt als Swatch
in het Swatch-venster
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Patroonvulling en patroon schalen
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1. Maak een vorm en vul deze met het patroon swatch

2. Maak een kopie van de vorm. Selecteer de kopie.

3. Ga naar de Scale-tool in het gereedschappen-venster links.

4. Dubbelklik om de opties te voorschijn te roepen. Zorg dat alleen de Transform Patterns aan-
gevinkt is. Kies een percentage. Klik op OK.

lllustrator Tutorials Design Patterns 5


https://bookstack.hku.nl/uploads/images/gallery/2023-03/adobe-ill-tuts-design-patterns5.jpg

Recolor Artwork

Recolor Artwork

( ~ ) Anwork colors

Achtergrondvlak toevoegen aan patroon

1. Kies voor geen lijnvulling. Maak een kopie van het viak met de patroonvulling.

2. Ga naar Edit > Paste in Back.

3. Ga naar de Swatches-venster en kies een kleur voor de achtergrond.

4. Zorg dat zowel het achtergrondvlak als de patroonvulling beide geselecteerd zijn.
5. Ga naar Edit > Edit Colors > Recolor Artwork

6. Klik op de Advanced setting.

7. Kies om eigen kleurgroep (A) te veranderen of een andere kleurgroep (B)

lllustrator Tutorials Design Patterns 6


https://bookstack.hku.nl/uploads/images/gallery/2023-03/adobe-ill-tuts-design-patterns6.jpg

1. Image Trace

~
Originele scan / Image Trace: 3 color
: " [ oo | 1mage Trace | Color Giide »
N 3 P, | |
Il ( #@a B 000
™~ _f { J\J[\\J N \ — N ™S i . Preset: Custom v | =
S ] NJ
~J ‘) ~J 3 View: Tracing Result - o
~ A L \ o —i % \ Mode:  Color sk
/ \ | ; P < S Colors: -O- 3
N\ | 5 \ 2 30
k \LJ‘ - ) N/ B { " ~ Advanced
@ \ S \Y) LY \ S Paths: lo} 50%
’ \ - p— D \ T Low High
\ \ \ 7 ) . N \ / i ity o st
N \ ‘.‘ Nk \ Less More
W J \ ] ( \J & J Nolse; Q) ———————————— Spx
\ a ~ N\ ( ), 1 100
7 / — = 7_,/ ‘ - \__ ;* \,’/ o T 7_,// Mechod: [0 D
J /-1\\ <“ -y J Y _.,;\ ~ i :
Fain hY I~ \
O 1\ J (J A Ty ) 1 ) — Options: (] Snap Curves To Lines.
= i & oy A B ignore White
) s ~J 5 = e —
(M~ s \ % ; P o \ 3 Paths: 45 Colors: 1
il b \f\ \ \*\ ) s SR % 1 '?T\ 3 N Anchors: 1505
\J N E—

Instellingen voor ‘3 color’ aangepast
Options: Ignore white (voor transparante achtergrond

Image Trace: Sketched Art Image Trace: Line Art

Image Trace > Sketched art Image Trace > Line art
Threshold > 244, Paths > 70%, Create Fills Paths > 244, Create Strokes, 50 px
Options: Ignore White. Options: Ignore White
2. Expand
o i;f E'j i 0
ooy s é*
Bao mon
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g 1
Object > Expand > vormen worden omgezet in Object > Expand > vormen worden omgezet
vullingen in lijn
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3. Object > Path > Simplify

Simplify Het aantal
ankerpunten
zorgt ervoor dat
je bestand zwaar
wordt.

Het aantal kun

je via de Simplify
tool verminderen.
Hou wel in de
gaten dat je lijn-
vulling niet teveel
gaat vervormen.

4. Aanpassing artwork

Ul

Voordat je een patroon maakt kun je optisch je artwork aanpassen.

1. Selecteer met de Lasso-tool (shortcut Q) elementen die je wilt verplaatsen/verwijderen/roteren
2. Ga met de witte selectie-pijl (A) op de lijn staan en verplaatst of verwijder (backspace) of roteer
(R).
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ADOBE INDESIGN 2023 basistutorial

Opzetten A4 pagina

Werkomgeving

Foto’s plaatsen

Tekst bewerken

Grid maken en aanpassen

Meerdere foto’s plaatsen

Bewaar en exporteer Indesign-document als pdf-bestand
Bewaar Indesign-document als Package

Tekst en tekstalinea’s (Paragraphs) bewerken mbv de Controlvenster
Beeld in tekst plaatsen

Beeld in tekst over meerdere regels met samengesteld pad

Object effecten toegepast op tekst

=
I
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Blending effect: Multiply

Tekstvervorming, -aanpassing + Direct Selection Tool

Tekst langs een pad + opties

Opmaak boekje (8) pagina’s

Masterpages (A-Parent) > Vaste elementen en paginacijfers
Masterpages (A-Parent) > Vaste elementen en paginacijfers (vervolg)
Stramienpagina [None] en toepassing B-Parent

Vaste elementen loskoppelen (overwrite) van je stramienpagina’s
Import options PDF-bestand

Print Booklet

Acrobat Reader instellingen + Printspecificaties Oudenoord
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Foto’s plaatsen

File Edit

Layout Type

QOpen... xO
Browse in Bridge...
Open Recent ¥
Close =W
Save S
Save As... it 4

Save a Copy... -

2

-

Search Adobe Stock...
Place... -h ®D
Place from CC Libraries...

Import XML.., R
Import PDF Comments...

Adobe PDF Presets
Export...
Share for Review...

Publish Online...
Recently Published >

Foto's plaatsen : 3 mogelljkheden

1. Flle > Place (D) > Mavigeer naar foto > Open > Klik linksboven in de pagina >
Foto verschijnt in werkelijke grootte, kader past zich aan.

2. Flle > Place > Navigeer naar foto > Open > klik en sleep een rechthoek op de pagi-
na = Foto past zich aan formaat kader

3. Plaats eerst een rechthoekkader. File > Place > Navigeer naar foto > Open > foto
hangt aan je cursor > klik op kader of foto verschijnt meteen in kader. Afnankelijk van
grootte kader laat die een deel van de foto zien.

Tekst bewerken
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Werken met tekst

1. Selecteer links in de gereedschap-
pen-venster de Tekstkader-opfie
(letter T)

2 Trek een rechthoek in de folo. De
tekstkader is de herkennen aan de
cursor linksboven in de kader.

3. Typ een tekst in en selecteer de
tekst.

4. Ga naar de controkvenster boven-
in en kies achtereenvolgens een
lettertype uit, de lettergrootte, ruimte
tussen de letters, kleur

In dit voorbeeld is gekozen voor
lettertype: Eurostyle Extended,
grootte=72 pt, spatiéring (V/A)= 420,
Kleur= 60% rood.

Tekstkader vullen met place-
holder text:

Plaats een tekstkader, bepaal letter-
type, grootte enz.

Ga naar menu > Type > Fill with
Placenolder Text

Je kunt de tekst ook
bewerken onder Character in
de Properties-venster rechts.

Ruimte tussen regels
(=Interlinle) vergroten

Characier

Faragraph

Initlaal maken.

Klik in de Control-panel op
de Alinea-teken (onder de
letter A)

Bepaal hoogte van de eerste
letier (=aantal regels)
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Grid maken en aanpassen

Grid aanpassen met

de Gap-tool

1. Ga naar de Gap-tool

2. Plaats de Gap-tool tus-
sen de frames en verschuif
naar links of rechis

Om alleen de ruimte
tussen 2 frames te pakken
selecteer je tegelijk de
Shift-toets

Grid maken

1. Selecteer links in de gereedschappen-venster de rechthoekframe.

2 Trek een rechthoek van linksboven naar rechtsonder zonder de muis los te laten. Klik 2x op pijltoets naar boven en naar
rechts om 3 kaders te krijgen. Laat nu de muis los.

NB. De afstand tussen de kaders kun je van te voren bepalen onder menu > Lay-out > Margins and Columns > Gutter

Meerdere foto’s piaatsen

Foto’'s in de frames plaatsen Frames proportiooneel vullen

LM R 3. Om de frames proportioneel te vullen met de foto’s:

2. Navigeer naar je foto’s. Selecteer hoeveelneid foto's die Selecteer alle foto's, ga naar Propertles > Frame Fit-
je nodig hebt (met Shift-toets ingedrukt). Hoeveelheid foto’s ting en klik op het 1ste icoontje.
hangt nu aan je cursor.

Of ga naar menu > Object > Fitting > Fill Frame Propor-

Klik 1 voor 1 in de kaders om de foto's te plaatsen. tionally
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Bewaar en exporteer Indesign-document als pdf-bestand
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Zorg dat je het document regelmatig bewaard
onder menu > File > Save of Save as

Bewaar als pdi-bestand:
menu: File > Export

Navigeer naar een folder om het pdi-bestand te
bewaren.

Als je maar 1 pagina hebt opgemaakt laat je de
instellingen zoals die is en klik op Export
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Bewaar Indesign-document als Package
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Bewaar het document als Package als je bv. op een andere computer wilt werken.

Ga naar menu File > Package: Navigeer naar een lokatie om de folder te bewaren.
Alle gebruikie lettertypes, teksten en grafische afbeeldingen en informatie voor de printer worden in 1
map verzameld.

Zet je folder op een usb-stick.
(Als je op een ander computer verder gaat werken moet je er eerst voor zorgen dat dezelfde lettertypes
geinstalleerd zijn en de afbeeldingen opnieuw linken_)
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Tekst en tekstalinea’s (Paragraphs) bewerken mbv de Controlvenster bovenin

1 Uritatecum utas enimin et occaecaesto earch-
ilique consequi sequis alitas ullabor alia ven-
dae cora ventia cusandu ntecabo. Nam est
aut que et laborec tatioss itiatiunt guiam har-
untem aborporrum fuga. Consequ atumaguis
debistium quis resed quia conserum vollaut
quiatio beris nisquam arum fuga.

S

3 Uritatecum utas enimin et occaecaesto earch-

iligue consequi sequis alitas ullabor alia ven-
dae cora ventia cusandu ntecabo. Nam est
aut que et laborec tatioss itiatiunt quiam ha-
runtem aborporrum fuga. Consequ atumquis
debistium quis resed quia conserum vollaut
quiatio beris nisquam arum fuga. Agnatempe-

ro doloriam senihillit omnis inciis.

Alinea 1: Arial lettertype, 12 pt, linkslijnend, in het rood: Bold, /talic en Bold Halic
Alinea 2 Arnial lettertype, 12 pt, leading (interlinie) 6 pt.
Alinea 3: Arial lettertype, 12 pt, leading (interlinie) 24 pt.

4Consequ atumquis
debistium quis resed
gquia conserum vollaut
quiatio beris nisquam
arum Tuga. Agnatem-
pero doloriam senihillit
omnis Iinciis exerferum
autempora

6 Aspedis comnimi llendel et facest, quia dolor
soluptatem undebitemos aut amust, toressit
omnimped ererero quamus.

Bitem ventiaest qui consequam iderspe
llatem volorerum con eliquibus pelenie nimos-
sus event autemquat.

Inciam experum quia voluptur aci untum
ipsaera int am endit quate re poratem qui ut
explic tem estrum voluptu verit, natus exper

ilit, gue nesto cus est, sam fuga.

Epernatur, aceperrum voluptibea ius, ommo-
luptatus dolecusam acimendi niant, odit omni-
moditiam quamus.

Dunti videbitaque vellatemolum rem re-
runtis  doloreius nemodit  evendelent.
Nem fugitia ssimusdae peditis ut fugiae do-
luptur, tet wvoluptagui wvolorae dolesciunde

5 Uit tﬁcum utas enimin &t occagca lgt? :

€archiique consequl e UIS&IHS d

d VEN ae BUI'E‘.' E Us 0

dh € dlorec IUSS atunt

am ar a orporrum UHSE{]U
& ITE% 1S [ESE ma C0

Aj nalé'r’ﬁblerm oonarﬁssg'n l{ or%r#l@ ga.

7 Untatecum UTAS enimin et occaecaesto

earchiligue consequi sequis aLmas ullabor
aliavendae cota ventia . ntecabo. Nam
est aut que et laborec tatioss itiatiunt quiam
haruntem aborporrum fuga. Conse-
qu #mais dehistium quis resed quia conserum

vollaut gtiatte beris nisgamauTigeAgeaTpendis

ansenihillit omnis inciis exerferum 5,tempora

Alinea 4 & 5: Aanpassing letterbreedte (200%)
en letterhoogte (200%)

Alinea 6 Alinea uitlijningen (regelval):
linkslijnend, rechislijnend, gecentreerd, in blok
gezet (justify)met laatse regel linkslijnend, alle
regels in blok gezet.

Alinea 7. Spelen met verschillende opties (in
het rood): omzetten naar kapitalen, sub- en
superscript, spatiéringen, doorgestreept.
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Beeld in tekst plaatsen

I M na E 3. Plaats een beeld in de tekst: ga naar
. menu > File > Place > selecteer beeld.
i‘r 2 Beeld verschijnt in de tekst
bl - [
, (,
i | + ' -
=

] g\

Beeld in tekst over meerdere regels met samengesteld pad

1. Maak een woord met de Tekst-tool.
en bewerk deze: Kies lettertype, -grootie.
In dit voorbeeld: Impakt, 86 pt.

2. Maak hier lettercontouren van: ga naar
menu > Type > Create Outlines

1. Maak een hele zin op in een smalle
tekstkader met de Tekst-tool en bewerk deze:
Kies lettertype, -grootte, pas interlinie aan. In
dit voorbeeld: Impakt, 86 pt_, leading (interlinie)
68 pt

2. Maak hier lettercontouren van: ga naar
menu > Type > Create Outlines

3. Als je nu probeert een tekst te plaatsen
verschijnt deze aan je cursor en kun je deze
maar toepassen op 1 regel.

IMAGE
TEMS L CUER
MEERDERE
REGELS

4. Koppel eerst alle letters los: menu > n

Object = Ungroup

5. Maak van de losse letters een I
samengestelde pad: ga naar menu > Object

> Paths > Make Compound Path

3. Ga naar File > Place. Plaats de afbeelding
in de tekst.
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Object effecten toegepast op tekst

Object effecten kun je vinden onder menu > Object > Effects

Maak een tekst met de Text-tool. Kopieer deze een paar keer. Selecieer de eersie.
Klik op de zwarte selectiepijl en ga naar menu > Object > Effects.
Of naar de Controlpanel bovenin en klik op het fx-icoontje.

Probeer achtereenvolgens onderstaande object effecten uit.
NB. Deze effecten werken niet als je de tekst selecteert, wel op (tekst)kaders!

DhDESHAUUN
INNER SHADOW

OUTERGLOW  |NNER GL(

BEVEL & EMBOSS

SATIN BASIC FEATHER
DIRFCTIONAT GRAD!

Blending effect: Multiply

‘ MAGENTA

Plaats objecten of teksten over elkaar heen. Selecteer ze allemaal.
Ga naar menu: Window > Effects. Kies voor de Blending Mode
optie Multiply.

Bij Opacity kun je evt. de dekking van de kleur bepalen
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Tekstvervorming, -aanpassing + Direct Selection Tool

1. Maak contouren van je opgemaakte tekst:
Type > Create Outlines. Ga daarma met de
Direct Selection Tool (2e pijltije van boven)
naar 1 van de witte ankerpuntjes op de
letters en sleep deze naar binnen of buiten

2. Maak contouren van je tekst: Type >
Create Outlines. Ga naar de Controlpanel

en kies voor Stroke in een kleur. Geef de
dikte aan, bv. 3 pt

Selecteer met de Direct Selection Tool
(een deel) van de tekst.

Ga onder Proporties rechts, naar Convert
Peints en kies voor de laatste optie
(Symmetrical)

3. Maak contouren van je opgemaakte tekst:

Type > Create Outlines. Zet een zwart viak
achter de helft van de tekst. Ga naar Object
> Arrange > Sent to Back.

Selecteer de tekst + het viak. Ga naar Object

> Pathfinder > Exclude Overlap

Tekst langs een pad + opties

1a. Maak met de pencil-tool een a Pats

golvende lijn. Geef de lijn een kleur om @dﬁ ':%g &
het even zichtbaar te maken SN Sq}

(Stroke/lijn optie in de Controlpanel). ona Path i, ,.@'e" 4 path type o %
(Ga naar de Tekst-tool, hou deze , ﬁ{, % ) Py
ingedrukt en kies voor de optie Typeon  ° % “dpeon Fd h,

a path. Ga met de goli-cursor ergens naPathy o gpathiype o My
naar het begin van het pad en begin met .
typen. Kopieer de golvende tekst 2x. %
Ga naar menu > Type > Type on a Path

> Options en kies bij Effect voor Skew type on @
(1b) of Stair Step (1c).

Kies nu bij Stroke (lijn) voor None.

2a. Maak met de Ellips-tool een cirkel. w8
(Ga naar de Teksi-tool, optie Type on a a°
path. Ga met de goli-cursor ergens op $
de cirkel staan en begin te typen, totdat & 22
je bijna rond bent. Selecteer de tekst en %

maak de ruimte tussen de letters groter %

in de Controlpanel (V/A). s

2b. Tekst omdraaien langs binnen-pad: %

(Ga naar menu > Type > Type on a Path d’a@ Q;Q'
> Options en kies voor Flip S6ue, 1'3"@1‘
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Opmaak boekje (8) pagina’'s

1. Maak een nieuw document op. File > New
> Document

Het formaat is een staand A5, Facing
Pages. Het aantal pagina’s moet een
veelvoud van 4 zijn (dus 4,8,12,16 enz) In

dit voorbeeld: 8 pagina’s. Marges boven,
beneden, buiten: 10 mm, binnenkant: 12 mm.
Bleed (aflopend boven, beneden, buiten) > 3
mm, binnen > 0 mm.

In de paginavenster rechis worden 8 pagina’s
getoond met een kleine letter A. Deze
verwijst naar de siramienpagina’s bovenin:
A-Parent (voorheen A-Master genoemd).

Op deze pagina’s kun je vaste elemenien
plaatsen zoals logo's, achiergrond,
paginacijfers. Deze verschijnen automatisch
op de aangemaakie pagina’s eronder

Properties £ Pages CC Librarie
[None]

A-Parent

Masterpages (A-Parent) > Vaste elementen en paginacijfers

1. Selecteer de Parent-
pages door op de naam te
klikken.

2_Plaats een rode
rechthoekkader aan

de onderkant van de
linkerpagina en een
blauwe aan de rechterkant
van de rechierpagina.

Op alle volgende pagina’s
verschijnen dezelfde
elementen.

Doorlopende paginanummering (op een 2e laag)

1. Maak een nieuwe laag aan Windows > Layers: klik op het plus-teken onderin.
2. Maak met de Tekst-tool een kleine tekstkadertje linksonder of in het midden,
waar de paginacijfer moet komen.

2. Ga naar menu > Type > Insert Special Character > Markers > Current
Pagenumber.

3. Een letter A (van ‘A’-parent) verschijnt. Deze kun je veranderen van letiertype
en grootte.
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Masterpages (A-Parent) > Vaste elementen en paginacijfers (vervolg)

Door de paginacijfers op een laag erboven te zetten voorkom je dat
je paginacijfer onder een foto of een viak verdwijnt.

o Layers Links

» paginacijfers
1. Maak een nieuwe laag aan: menu Windows > Layers: klik op het | Layer1
plus-teken onderin. Dubbelklik op Layer 2 en verander de naam.
Maak met de Tekst-tool een kleine tekstkaderije linksonder of in het Pages: AA, 2 Layers
midden, waar de paginacijfer moet komen.

2. (Ga dan naar menu > Type > Insert Special Character > Markers > Current Pagenumber.

Bulleted & Mumbered Lists ¥
Insert Special Character >  Symbols »
Insert White Space > Markers i8] Current Page Number
Insert Break Character > Hyphens and Dashes * Mext Page Number
Fill with Placeholder Text Quotation Marks > Previous Page Number
Other ¥  Section Marker

oo Liddam Pharastorne

3. Een letter A (van ‘A’-parent) verschijnt. Deze kun je in de Control-panel veranderen van lettertype en
grootte.

4. Zorg dat de A linkslijnend uitgelijnd is. Sleep een kopie (alt/option-knop ingedrukt) naar de rechterkant.
Selecteer de A en maak deze rechislijnend.
Als je nu op 1 van de pagina’s onder klikt zie dat deze voorzien is van een paginacijier.

Stramienpagina [None] en toepassing B-Parent

jes ¢ Pages  CC Librarie Een 2e stramienpagina opzetten.

optielijst ' 1. Ga naar de optielijst rechtsbovenin. Kies uit de lijst voor New Parent.
Klik op OK. Dubbelklik op B-Parent om deze te bewerken

2. Maak bv. met de rechthoek-tool een vlak in een kleur met een 20% tint
over de hele linkerpagina. Doe hetzelfde op de rechierpagina.

3. Sleep de linkerpagina naar pag.2 en de rechter naar pag.7
Deze pagina’s zijn nu voorzien van de letter B.

4. Voor de cover (pag.1) en de achterkant (pag.8) wordt geen stramien
toegepast: Sleep de lege [None] pagina naar pag. 1 en 8.

Paginacijfers door laten lopen.

Om alle pagina’s te voorzien van doorlopende cijfers moet de
paginanummers-aanduiding op stramienpagina A-Parent gekopieerd
worden naar de B-Parent:

1. Selecteer beide tekstkaders met de A. Kopieer deze (Cmd-C).

2. Ga naar de B-Parent pagina’s, dan naar menu > Edit > Paste in Place
om Ze op exact dezelfde plek te plaatsen. ‘A’ is veranderd in ‘B’
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Vaste elementen loskoppelen (overwrite) van je stramienpagina’s

> Layers Links
@ » paginacijfers
Lol i » Layer 1

Pages: AA, 2 Layers

COVER
I

Hooldutuk 1

L

- I I
‘H“ "

T T— E_--
— - —
I 3 i—a—= |
A IS S S ——
=EEEEE=E

Properties < Pages CC Librarie

[MNome]
A-Parent

B=Parent

Zorg dat je verder in Layer 1 werkt.

Maak de volgende pagina’s op met beeld en tekst n.a.v. je
overzichischets.

Fragror s

wjeed sRel

fdstuk 3 fdstuk 3 fdstuk 3

Een vast element op een gewone pagina herken je aan de
stippellijnkaders, en kun je niet selecteren.

Om een element te verwijderen of naar voren te halen moet je deze
alsvolgt selecteren:

Met de Shift-Cmd toets ingedrukt selecteer je het object- of tekstkader
en kun je deze verwijderen of naar voren halen: menu Object >
Arrange > Bring to Front

Wanneer je toch bepaalde elementen van een stramienpagina
wilt toepassen, zoals op de voor- en achterpagina, klik je op de
betreftende siramienpagina (bv. A-Parent).

Klik op het element om te selecteren, kopieer deze (Cmd-C).
Ga naar de pagina, dan naar menu > Edit > Paste in Place
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Import options PDF-bestand

Net zoals foto’s kun je PDF-bestanden pagina voor pagina plaatsen in je document.

Place POF [boskje A5.paf)

Kiou ¢ am = Indealgn 2029 mt 2] o

Gedeckd
£ Min Dri. o el GO‘JEK
o B oo st
= Buras.. 5 o
A Apps B dealyn 30 bashndd
i Indeakan T0. sistetnial
[ Docum- = Wedeign 50 noriad ki g

2 » Transparent Rackgs o
(&} Dewmio,
Ll Toaal pages: &
= Fims Imger! Sptions
: Frplacn Solioctnd Rem
Gal Afbecid. Cigane SULE Caplioig
£ Meteion... (" canca ) o
e serece . EEEI Camat ) (e )

£2 Google. : :

(Ga naar File > Place. Zorg dat Show Import Options Selecteer in het dialoogvenster: All Pages.
aangevinkt is. Replace Selected ltem staat standaard aan.  Bij Options kies je voor Crop.

Om te voorkomen dat je per ongeluk iets geselecteerd hebt Desgewenst kun je ook specifieke pagina’s
Zet je deze uit. Navigeer naar je PDF-bestand = Open. plaatsen met een transparante achtergrond.

e In je document kun je de pagina’s plaatsen op
EaeE] ====m===e= | aparte pagina’s of in kleiner formaat.
De kaders kun je voorzien van een lijn of zelf

een Drop Shadow effect

Als je thuis een boekje wilt uitprinten: ! ﬂ

Ga naar File > Print Booklet. De instelling staat -

standaard op 2_up Saddle Stitch. 4 Pages 8 Pages 12 Pages 16 Pages
De pagina’s worden op een zodanige manier i s il
tegenover elkaar geplaatst dat je ze dubbelzijdig kunt

uitprinten en dmv nietjes bij elkaar kunt binden.

)

HH

N«

H B

Ga naar Printersettings
; o > Setup om de juiste
Ga naar Preview om de volgorde en Egigtl?“e VAR PARIGELE
laatsing te bekijken. I . L

&j 8 pﬂgnfgah e lsgm TR yme—— Bij Page Position kies je
elke tegenoverliggende pagina's moet @ zijn voor Centred
(247, 6+3, 4+5)
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P,

Acrobat Reader instellingen + Printspecificaties Oudenoord

Afdrukken

Printar:  Brother DCP-J41200W @ Gaavancesrd

-

Kopiedn; 1
drukken pagina's
O A Hisidige

Ber oplies

Pagina's

Pagina vergrotenverkleinen & werwerken (1)

Helg

Aldrukkan in grijsschaal [wart-wit)

FAT 04 ¥ 209,% men

| Zorg dat je je Indesign bestand

als PDF hebt geéxporteerd als
losse pagina’s.

Open in Acrobat Reader je PDF-
bestand.
1. Ga naar Bestand > Afdrukken

Grasite Paglar Meardere EAEK cuv;ﬁ - g
Subsat van boght  Beics fijden 5 m - =
Elzdan van 1 ot 2 _
Binding: Links B - gg!«
Aldnakstand:
O staand fggend
Autamatischwhaging'a roteren binnan el wel u a
Pagina 1 van 4 {1] Pagina 2 van 4 (7)
Opmerkingen & Formulanen
Document e markeringan a8 Dpmerkingan sameneaten 2 |r| het Afdruk venster kies je
Pagina-nstalling, . Primar... Annililaran =] dE p[intEr_
< - aantal pagina’s
- print als Boek
- dubbelzijdig (beide zijden)
Printspecificaties Oudenoord - aantal bladen (in dit voorbeeld:

EXPORTING PDF

InDesign

Exporting o PDF from InDesign .
- GotoFile w Export...
- Format Adobe POF (Prirt) (s [l)

- Cligk on Sva

Choose the following settings:

- Gararal [ses 1)
— [High Guality Prirt]
- Pages

- Marks and Bleeds (ses EI)

Crop Marks

- Uz Document Blesd Ssttings
{preset oti Fils » Document Sstup...}

- Output (saa [}
Color Convarsion

Corert to Destination
- Duostiration

Adobs RGE (1998) or Cooted FOGRAIR
- Profils Irahusion Polioy:

Inchuds Dastiration P‘mﬁlc

- Cliok on Ecport [ses )

[y ou want to sove this oz a preset

- (=)
- Sove Preset s PRINT workshop  (searfll}

- Cligk on Sove Prasst. .

- Cligk gn CK

[ 1 e '

2 bladen A4 formaat voor 8p. A5.
Voor 12 pag. heb je 3 bladen
nodig, voor 16 pag. 4 enz.)

- binding links

- staand

- afthankelijk van printer kies je
de optie Automatisch pagina’s
roteren.

Check in de Preview venster of
de pagina’s goed geordend en
geplaatst zijn.

Links: de printspecificaties als je
op Oudenoord gaat printen
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